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Open Database 
Choose File > Open Database from database menu or choose Open Database 
item from the list of tables shortcut menu or list of queries shortcut menu. 

Close Database 
Choose File > Close Database from database menu or choose Close Database 
item from the list of tables shortcut menu or list of queries shortcut menu. 

Compact Database 
Choose Tools > Compact from the database menu. 

Repair Database 
Choose Tools > Repair from the database menu 

Open Database Relations 
Choose Database Relation from the database tool bar. 

Edit Database Relations 
First open the database relations. 
Select relation you want to edit from the list on the left side. Now you can 
edit selected relation on the right side.  
For easy editing of Attributes property you can use shortcut menu. 

New Database Relation 
First open the database relations. 
Choose Add New Relation from the database relations list shortcut menu. 

Remove Database Relation 
First open the database relations. 
Right click relation you want to remove. 
Choose Remove Relation from the database relations list shortcut menu. 
 
 
 
 
 



 
DOCUMENTATION

 

6/21                                (c) 2005 dbtoolsplus 
 

 

Open Database Properties 
Choose Database Properties from the database tool bar. 

Edit Database Properties 
First open the database properties. 
Select property you want to edit from the list on the left side. Now you can 
edit selected property on the right side.  

New Database Property 
First open the database properties. 
Choose Add New Property from the database properties list shortcut menu. 

Remove Database Property 
First open the database properties. 
Right click property you want to remove. 
Choose Remove Property from the database properties list shortcut menu. 
You can remove only not built-in properties. 

Add Predefined Database Property 
First open the database properties. 
Choose Add Predefined Property > Name of property. 
There is a list of known properties not found in the list of properties on the 
left side. 

Open Table 
Select table you want to open from the list of tables. 
Click Open button or choose Open Table from the list of tables shortcut 
menu. 
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Edit Table 
You can edit table after you open it.  
For editing you can use standard tools from the tool bar. 
 
 
There are three more tools on the right side of the tool bar:  
Hide column 
Freeze column 
Export (Exporting table to CSV file) 

Rename Table 
Choose Rename Table from the list of tables shortcut menu. 

New Table 
Click New button or choose Add New Table from the list of tables shortcut 
menu. 

Remove Table 
Select table you want to remove from the list of tables. 
Choose Remove Table from the list of tables shortcut menu. 

Copy Table 
Select table you want to copy from the list of tables. 
Choose Copy Table from the list of tables shortcut menu. 
Question dialog appears. If you want to copy only a structure of the table 
then click NO. If you want to copy data too click YES. 

Design Table 
Select table you want to design from the list of tables. 
Click Design button or choose Design Table from the list of tables shortcut 
menu. 
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Edit Table Field 
First open design table form. 
Select field you want to edit from the list on the left side. Now you can edit 
selected field on the right side. 

Edit Field Properties 
First open design table form. 
Select field and property you want to edit from the lists on the left side. Now 
you can edit selected property on the right side. 
For easy editing of Attributes and Type properties you can use Value edit 
shortcut menu. 

New Table Field 
First open design table form. 
Choose Add New Field from the fields shortcut menu. 

Insert Table Field 
First open design table form. 
Choose Insert New Field from the fields shortcut menu. 

Change Order of Table Fields 
First open design table form. 
Select field you want to move up or down. Choose Move Up or Move Down 
from then fields shortcut menu. 

Remove Table Field 
First open design table form. 
Select field you want to remove. Choose Remove Field from the fields 
shortcut menu. 

New Table Field Property 
First open design table form. 
Select field you want to add property. 
Choose Add New Property from the properties shortcut menu. 
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Remove Table Field Property 
First open design table form. 
Select field you want to remove property. 
Right click property you want to remove. 
Choose Remove Property from the properties shortcut menu. 
You can remove only not built-in properties. 

Add Predefined Table Field Property 
First open design table form. 
Select field you want to add predefined property. 
Choose Add Predefined Property > Name of property. 
There is a list of known properties not found in the list of properties on the 
left side. 

Open Table Properties 
First open design table form. 
Choose Table Properties from the design table tool bar. 

Edit Table Properties 
First open the table properties. 
Select property you want to edit from the list on the left side. Now you can 
edit selected property on the right side.  

New Table Property 
First open the table properties. 
Choose Add New Property from the table properties list shortcut menu. 

Remove Table Property 
First open the table properties. 
Right click property you want to remove. 
Choose Remove Property from the table properties list shortcut menu. 
You can remove only not built-in properties. 
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Add Predefined Table Property 
First open the table properties. 
Choose Add Predefined Property > Name of property. 
There is a list of known properties not found in the list of properties on the 
left side. 

Open Table Indexes 
First open design table form. 
Choose Table Indexes from the design table tool bar. 

New Table Index 
First open the table indexes. 
Choose Add New Index from the table indexes shortcut menu. 

Remove Table Index 
First open the table indexes. 
Right click index you want to remove. 
Choose Remove Index from the table indexes shortcut menu. 

Open Query 
Select query you want to open from the list of queries. 
Click Open button or choose Open Query from the list of queries shortcut 
menu. This will run a query. If the query type is SELECT than table of result 
will open. You can edit this table. 

Rename Query 
Choose Rename Query from the list of queries shortcut menu. 

New Query 
Click New button or choose Add New Query from the list of queries shortcut 
menu. 

Remove Query 
Select query you want to remove from the list of queries. 
Choose Remove Query from the list of queries shortcut menu. 
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Copy Query 
Select query you want to copy from the list of queries. 
Choose Copy Query from the list of queries shortcut menu. 

Design Query 
Select query you want to design from the list of queries. 
Click Design button or choose Design Query from the list of queries shortcut 
menu. 

Open Query Properties 
First open design query form. 
Choose Query Properties from the design query tool bar. 

Edit Query Properties 
First open the query properties. 
Select property you want to edit from the list on the left side. Now you can 
edit selected property on the right side.  

New Query Property 
First open the query properties. 
Choose Add New Property from the query properties list shortcut menu. 

Remove Query Property 
First open the query properties. 
Right click property you want to remove. 
Choose Remove Property from the query properties list shortcut menu. 
You can remove only not built-in properties. 

Add Predefined Query Property 
First open the query properties. 
Choose Add Predefined Property > Name of property. 
There is a list of known properties not found in the list of properties on the 
left side. 
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Parse Query 
You can found out if a query has correct SQL command before you save it. 
Choose Parse Query from design query tool bar. 
 

Import Tables and Queries 
Choose File > Get External Data > Import from database menu or choose Get 
External Data > Import from tables or queries shortcut menu. 
Select tables and/or queries you want to import and click Import button. 

Link Tables 
Choose File > Get External Data > Link Tables from database menu or 
choose Get External Data > Import from tables shortcut menu. 
Select tables you want to link and click Link button. 

Create Database Documentation 
You can simply create text documentation about all database properties, 
tables and queries. 
Choose File > Documentation. Dialog will appears. Select items you want to 
include in documentation and click OK button. 

Open Query Analyzer 
Choose Tools > Query Analyzer from the database menu. 
The Query Analyzer remembers last query. 
Now you can type a query and/or open query from a file or save query to a 
file.  
Before you run query you can parse a query by choosing Parse Query from 
the query analyzer tool bar or from shortcut menu. 
The number of rows affected will appears in the message field. 
After that you can run a query by choosing Run Query from the query 
analyzer tool bar.  
 
If a query type is SELECT table with query result will appears. 
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Open Script 
Choose Tools > Script from the database menu. 
Script allows you make a more database changes by one click. 
You can open script from a file or save script to a file. 
You can run a script from the external application. You have to run 
AccDBMan with paramater:    /cmd �script file name� 
 

Script Commands 
 
If any parameter contains space character it must by quoted. 
Line of comment starts by ' (apostrophe) or # or / 
 
AddTableField tableName, fieldName, dataType, [fieldSize] 
Add new field to table definition. 
tableName, text: table name 
fieldName, text: field name  
dataType, text (Boolean, Byte, Currency, Date, Double, GUID, Integer, Long, LongBinary, 
Memo, Single, Text): data type of field 
fieldSize, number: define size of field if field type is Text. 
 
ChangeTableFieldSize tableName, fieldName, fieldSize 
Change size of field only if field data type is Text. 
tableName, text: table name 
fieldName, text: field name 
fieldSize, number: field size 
 
ChangeTableFieldType tableName, fieldName, dataType, [fieldSize] 
Change data type of field. 
tableName, text: table name 
fieldName, text: field name 
dataType, text (Boolean, Byte, Currency, Date, Double, GUID, Integer, Long, LongBinary, 
Memo, Single, Text): new data type of field 
fieldSize, number: define size of field if field type is Text. 
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CloseDatabase 
Close database file 
 
CompactDatabase databaseFile 
Compact database. 
databaseFile, text: database file name 
 
 
CopyTable srcTableName, destTableName 
Copy table structure and data from table to the new table 
srcTableName, text: name of source table 
destTableName, text: name of new table 
 
CopyTableStructure srcTableName, destTableName 
Copy table structure of table to the new table. 
srcTableName, text: name of source table 
destTableName, text: name of new table 
 
CreateQuery queryName, SQL 
Create new query. 
queryName, text: query name 
SLQ, text: SQL command 
 
CreateTable tableName, fieldName, primaryIndex, fieldType, [fieldSize] 
Create table with. 
tableName, text: table name 
fieldName, text: name of first field 
primaryIndex, boolean (True, False): define if field has primary index 
fieldType, text (Boolean, Byte, Currency, Date, Double, GUID, Integer, Long, LongBinary, 
Memo, Single, Text): data type of field 
fieldSize, number: define size of field if field type is Text. 
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DocumentAllQueries fileName, [append] 
Create text documentation of all database queries. 
fileName, text: name of destination file 
append, boolean (True, False): Set True if you want append this documentation 
at the end of existing documentation in the specific file. Default value = 
False. 
 
DocumentAllTables fileName, [append] 
Create text documentation of all database tables. 
fileName, text: name of destination file 
append, boolean (True, False): Set True if you want append this documentation 
at the end of existing documentation in the specific file. Default value = 
False. 
 
DocumentCompleteDatabase fileName, [append] 
Create text documentation of database properties and all database tables 
and all database queries. 
fileName, text: name of destination file 
append, boolean (True, False): Set True if you want append this documentation 
at the end of existing documentation in the specific file. Default value = 
False. 
 
DocumentDatabase fileName, [append] 
Create text documentation of database properties. 
fileName, text: name of destination file 
append, boolean (True, False): Set True if you want append this documentation 
at the end of existing documentation in the specific file. Default value = 
False. 
 
DocumentQuery queryName, fileName, [append] 
Create text documentation of query. 
queryName, text: query name 
fileName, text: name of destination file 
append, boolean (True, False): Set True if you want append this documentation 
at the end of existing documentation in the specific file. Default value = 
False. 
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DocumentTable tableName, fileName, [append] 
Create text documentation of table. 
tableName, text: table name 
fileName, text: name of destination file 
append, boolean (True, False): Set True if you want append this documentation 
at the end of existing documentation in the specific file. Default value = 
False. 
 
ExportCustomQueryData query, fileName 
Export custom SELECT query to CSV file. 
query, text: SQL SELECT command 
fileName, text: destination CSV file name 
 
ExportQueryData queryName, fileName 
Export SELECT query to CSV file. 
queryName, text: table name 
fileName, text: destination CSV file name 
 
ExportTableData tableName, fileName  
Export table to CSV file. 
tableName, text: table name 
fileName, text: destination CSV file name 
 
ImportQuery databaseFile, queryName 
Import query from another database file. 
databaseFile, text: database file name 
queryName, text: query name 
 
ImportTable databaseFile, tableName 
Import table from another database file. 
databaseFile, text: database file name 
tableName, text: table name 
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LinkTable databaseFile, tableName 
Link table from another database file. 
databaseFile, text: database file name 
tableName, text: table name 
 
OpenDatabase databaseFile 
Open database file. You have to open database first for most of commands. 
databaseFile, text: database file name 
 
 
RemoveDatabaseProperty ropertyName 
Remove database property. 
propertyname, text: property name  
 
RemoveQuery queryName 
Remove query. 
queryName, text: query name 
 
RemoveQueryProperty queryName, propertyName 
Remove query property. 
queryName, text: query name 
propertyname, text: property name  
 
RemoveRelation relationName 
Remove database relation. 
relationName, text: relation name 
 
RemoveTable tableName 
Remove table. 
tableName, text: table name 
 
RemoveTableField tableName, fieldName 
Remove table field. 
tableName, text: table name 
fieldName, text: field name 
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RemoveTableFieldProperty tableName, fieldName, propertyName 
Remove table field propery. 
tableName, text: table name 
fieldName, text: field name 
propertyname, text: property name  
 
RemoveTableIndex tableName, fieldName 
Set table primary index. 
tableName, text: table name 
fieldName, text: field name for primary index 
 
RemoveTableProperty tableName, propertyName 
Remove table property. 
tableName, text: table name 
propertyname, text: property name  
 
RenameQuery oldQueryName, newQueryName 
Rename query. 
oldQueryName, text: Old query name 
newQueryName, text: New query name 
 
RenameTable oldTableName, newTableName 
Rename table. 
oldTableName, text: Old table name 
newTableName, text: New table name 
 
RepairDatabase databaseFile 
Repair database. 
databaseFile, text: database file name 
 
RunSQL ”SQL command 
Run SQL Command. 
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SetDatabaseProperty propertyName, dataType, value 
Set database property. If property does not exist SetDatabaseProperty will 
create it. 
propertyname, text: property name  
dataType, text (Boolean, Byte, Currency, Date, Double, GUID, Integer, Long, LongBinary, 
Memo, Single, Text): data type of field 
value, Text or Number: value of property 
 
SetQueryProperty queryName, propertyName, dataType, value 
Set query property. If property does not exist SetQueryProperty will create it. 
queryName, text: query name 
propertyname, text: property name  
dataType, text (Boolean, Byte, Currency, Date, Double, GUID, Integer, Long, LongBinary, 
Memo, Single, Text): data type of field 
value, Text or Number: value of property 
 
SetQuerySQL queryName, SQL 
Set query SQL command. 
queryName, text: query name 
SLQ, text: SQL command 
 
SetRelation relationName, primaryTable, primaryField, foreignTable, 
foreignField, attributes, partialReplica 
Set database relation. 
relationName, text: relation name 
primaryTable, text: primary table name 
primaryField, text: primary table field name 
foreignTable, text: foreign table name 
foreignField, text: foreign table field name 
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SetTableFieldProperty tableName, fieldName, propertyName, dataType, value 
Set table field propery. If property does not exist SetTableFieldProperty will 
create it. 
tableName, text: table name 
fieldName, text: field name 
propertyname, text: property name  
dataType, text (Boolean, Byte, Currency, Date, Double, GUID, Integer, Long, LongBinary, 
Memo, Single, Text): data type of field 
value, Text or Number: value of property 
 
SetTableIndex tableName, fieldName, ignoreNulls, primary, required, unique, order 
Set table index with specific settings. 
tableName, text: table name 
fieldName, text: field name for index 
ignoreNulls, boolean (True, False): Ignore Nulls attribute 
primary, boolean (True, False): Primary attribute 
required, boolean (True, False): Required attribute 
unique, boolean (True, False): Unique attribute 
order, text (ascedning, descending): Order attribute 
 
SetTableIndexDuplicatesOK tableName, fieldName 
Set table index with DuplicatesOK setting. 
tableName, text: table name 
fieldName, text: field name for index 
 
SetTableIndexNoDuplicates tableName, fieldName 
Set table index with NoDuplicates setting. 
tableName, text: table name 
fieldName, text: field name for index 
 
SetTablePrimaryIndex tableName, fieldName 
Set table primary index. 
tableName, text: table name 
fieldName, text: field name for primary index 
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SetTableProperty tableName, propertyName, dataType, value 
Set table property. If property does not exist SetTableProperty will create it. 
tableName, text: table name 
propertyname, text: property name  
dataType, text (Boolean, Byte, Currency, Date, Double, GUID, Integer, Long, LongBinary, 
Memo, Single, Text): data type of field 
value, Text or Number: value of property 
 


